Auth FGA status
History

Errors on Auth0 Dashboard

Current status of incident

Errors on Auth0 Dashboard

Current Status: Resolved | Last updated at September 18, 2025, 16:08 UTC

Affected environments: US-5 Production, JP-1 Production, US-4 Production, UK-1 Production, CA-1 Production, EU-2 Production, US-3 Production, US-1 Production, EU-1 Production, AU Production

History for this incident

September 18, 202516:08 UTC

Resolved

Services have been restored. A root cause analysis (RCA) will be posted here within 14 days. We sincerely apologize for the impact this had on you and your users.

September 18, 202515:17 UTC

Monitoring

Our Engineering team has applied the necessary changes and we are now seeing recovery and monitoring this issue.

September 18, 202515:14 UTC

Identified

Our Engineering team has reviewed the change to fix this issue and we will confirm shortly once we are seeing improvement.

September 18, 202514:56 UTC

Identified

Our Engineering team has identified the root cause of this issue and customers may notice errors when selecting the save button after making changes on the Auth0 Dashboard. We are working urgently applying necessary mitigation actions and we will provide another update here in approximately 30 minutes.

September 18, 202514:47 UTC

Investigating

We are continuing to review errors from this issue and provide updates as our investigation progresses. We will provide more information here in approximately 15 minutes.

September 18, 202514:39 UTC

Investigating

We are currently investigating an issue with Auth0 Dashboard. We will provide more information here shortly as our investigation progresses.